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Learn the fundamentals of using HP VEE

by following step-by-step examples.

The evaluation CD includes the following:

• HP VEE 5.0 evaluation copy

• I/O Libraries for RS-232 devices

• Starter set of instrument drivers

• 3-minute Introduction to HP VEE

• Tutorial on using HP VEE

• 3 HP VEE applications with step-by-step description

To run the HP VEE 5.0 evaluation software, you'll need:

• Microsoft Windows 95/NT (4.0 or higher) operating system

• An 80486 processor, 66 MHz or faster

• Minimum RAM of 16 MB (Windows 95), 32 MB (Window NT)

• Minimum display of 800x600 with 256 colors

• CD-ROM drive
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Introduction

What  is  HP  VEE?
HP VEE is a visual programming language for developing programs for

instrument control and data acquisition.  With HP VEE you create a visual

program by linking together functional objects to form a block diagram.

The range of functions within HP VEE makes it a universal tool for

measurement and control programs.

Using HP VEE, you can...

• Gather data from instrumentation and PC plug-in modules.

• Control interfaces and equipment (serial, HP-IB or GPIB, VXI).

• Display data using many different plots, alphanumeric displays, and
display objects.

• Load and use ActiveX Controls to add functionality to HP VEE.

• Communicate with other Windows programs using ActiveX
Automation.

• Save programs using many formats such as binary, ASCII, table formats.

• Process data as strings, arrays, bytes, records, etc.

• Compute, analyze and simulate from simple addition to FFTs, fitting,
integration, etc.

• Work with loops such as if/then/else, <, =, >, for, while, repeat until,
etc.

• Control and regulate to simulate data, measure and compute output
variables, etc.

• Create structured programs and user interfaces.

• Access any HP VEE panel over the World Wide Web.

• But above all:

Save time and money!
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Ins ta l l ing  HP  VEE  Eval uat i on  C opy
Installation for Windows 95/NT:

• Insert the CD in your PC's CD drive, and the evaluation software will
auto-run.  Or you can double-click on Win95_NT.exe in the CD’s root
directory.

• If you’re new to HP VEE, take the time to go through Introduction to

HP VEE and Applications to learn basic HP VEE operation and
concepts.

• Select Install Evaluation VEE

If you didn’t review Introduction to HP VEE and Applications, rerun
Win95_NT.exe when you have time to review these sections. 

Note: To evaluate HP VEE using a serial port (RS-232), install the I/O

libraries (hpiolibs.exe) from the CD.  For other interfaces, the I/O software

you need should be included with the I/O hardware you are using.

This evaluation copy provides a subset of the instrument drivers shipped

with HP VEE.  You can download additional drivers from the HP VEE web

site (www.hp.com/go/hpvee) under Support/Instrument Drivers.

Installation for Windows 3.1:  Follow the instructions above-you will

only be able to view Introduction to HP VEE and Applications.  The

evaluation software for HP VEE 5.0 only runs on Windows 95/NT.

Uninstalling the Evaluation Software

• From Windows, select Start → Settings → Control Panel, and run
Add/Remove Programs.

• Select Install/Uninstall, and select the entry for the HP VEE evaluation kit.

• Click on Add/Remove, and select Yes when asked for confirmation.

Evaluat ion  Copy  L i mi t a t i ons
The demo version of HP VEE provides the same functionality as the full

version.  However, you cannot save HP VEE programs with more than 50

objects.  The demo version becomes disabled after 60 days.
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Discover HP VEE!

This booklet contains three examples with step-by-step instructions

for you to create your first simple HP VEE programs.  These examples will

help you get acquainted with HP VEE and show you how it works. 

HP VEE  5 .0  New Features
Version 5.0 of HP VEE provides new functionality in three key areas:

• ActiveX Controls — you can now add ActiveX Controls to HP VEE.

• ActiveX Automation — you can now easily send and receive data from
other ActiveX applications, such as databases, spreadsheets, and word
processors.

• Web Enabled Functions — HP VEE now has a built-in web server so that
you can remotely monitor HP VEE programs over your intranet or the
World Wide Web.

This booklet does not provide examples that use these new features.  Please

visit the HP VEE web site (www.hp.com/go/hpvee) for application notes on

these features.  Also, refer to Help → Open Example within the HP VEE

evaluation software for examples that demonstrate use of these features.

Working  wi th  HP  VEE :  The  I n t er f ace
Double-click the left mouse button on the HP VEE symbol to start HP VEE.

The development environment is displayed.

The menu bar provides pull-down menus that contain the programming

objects of HP VEE.  The tool bar contains shortcut buttons for working

with programs and functions (Run, Stop, Save, etc.).  Refer to the later

sections of this booklet for a guide to HP VEE menu shortcuts.

HP VEE is operated via the keyboard, a mouse, and buttons on the tool bar. 

Menu Bar

Tool Bar
Run Key
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Here  are  the  main  ways  you  in teract  wi th  HP VEE  objects :
Getting objects from menus: 

• Click on the menu item with the left mouse button.

Moving objects within the development environment: 

• Move the mouse pointer onto the object or the blue title bar, hold the left
button down and move. 

Changing the size of objects: 

• Move the mouse pointer to the lower right corner until the pointer turns
into a right angle, then drag the object to its desired size.

Connecting (or wiring) objects: 

• Click the left mouse button near one of the pins (i.e., black dots at the
edge of the objects).  Move the mouse (dragging the wire) to the pin to
which you want to connect, and click there again.

Deleting existing connecting wires (i.e., lines): 

• Select Edit → Delete Line, then click on the connecting line to be
deleted. Note that there are two scissors symbols in the tool bar-one for
deleting objects and the other (to the right) for deleting connecting lines.

Selecting objects: 

• Click on an object (hold down the Ctrl key if several objects are being
selected). 

Changing the view of an object: 

Every object has two kinds of views. 

• Icon View: Click on the upper right corner of an open object.

• Open View: Double-click on the icon view of the object.

Opening an object’s Properties dialog box: 

• Position the mouse pointer over the object, and click the right mouse
button.  Or, double-click in the title bar to directly open the Properties

dialog box.

Deleting objects: 

• Open Properties and select Cut.

Moving the block diagram within the development environment:

• Hold down the left mouse button with the pointer in an empty area while
moving the mouse.
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Example 1:  Generating Random Numbers

This exercise will familiarize you with the general operation of HP VEE.

We will generate ten random numbers and display the values.  You will

work with the library of math functions, add a loop, and display the

numbers.

Genera te  a  Random Number  
1. Start a new program by selecting File → New.  

2. For maximum workspace, turn the Program Explorer off.  Select View.
If there is a checkmark next to Program Explorer, click on it to toggle
it off. 

3. Click on Device → Function & Object Browser (or click on the ƒx

key in the tool bar).  A window opens containing lists of mathematical
objects as well as user functions.  Select the following:

• Type → Built-in Functions

• Category → Probability & Statistics

• Member → random

• Create Formula (located at the bottom of the window)

4. The mouse pointer drags the outline of the object along with it.
Position the object in the upper left section of the work area by moving
the mouse and clicking the left mouse button again when the object is
where you want it. This object generates random numbers between the
values high and low.  

5. To set the lower limit, select Data → Constant → Real and place the
Real object to the left of the Random object.  Click on the input
window and type in the value -10.  Connect the output pin of the -10

object to the input pin labeled low on the Random object. 
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Note: You must connect objects to transfer data.  Data input pins are on the

left, and data output pins are on the right.  An object’s sequence pins (top

and bottom of the object) can be used to specify program execution, but are

seldom required.  HP VEE programs execute top to bottom, left to right.

6. Repeat the instructions in step #5 to create an upper limit of 10-
connecting the second object to the input terminal labeled high.

7. Get an object in which to display a random number.  Select Display →

Alphanumeric and position it to the right of the Random object.
Connect the data output (i.e., labeled Result) from the Random object
to the data input terminal on the AlphaNumeric display.  Your HP VEE
program should look  like this:

8. You are ready to run your program to ensure that it’s working so far.  Select
Debug → Run/Resume, or click on the triangular icon on the tool bar.  You
will see that we have generated and displayed one random number.

Sequence input pin

Data input 

pin

Data output

pin

Sequence output pin
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Create  a  Loop  to  Genera t e  Ten  Number s
1. Minimize the Random object by clicking on its upper right corner.

2. Delete the AlphaNumeric display by double-clicking on its upper left
corner or by opening its Properties dialog box (mouse pointer over
the display, click the right mouse button) and selecting Cut.

3. Add a new object that can display all ten numbers at once.  Select
Display → Logging AlphaNumeric and position the object to the
right of the random number object.  Connect the data output from the
Random Number object to the data input pin on the Logging

AlphaNumeric display.

4. To generate ten random numbers we’ll add a loop.  Get a For Loop by
selecting Flow → Repeat → For Count.  The default for the count is
10.  Connect the data output pin from the For Count object to the top
sequence pin of the Random object.  

5. Now close the loop. Select Flow → Repeat → Next and position the
object below the Random object.  Connect the bottom sequence pin of
the Random object to the Next object’s top sequence pin.

6. Run your program again.  If you don’t have the results you expect, first
check the connections between objects to ensure they match the
program shown below.
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Example 2:  Simulating, Analyzing and

Displaying Data

In this exercise you’ll learn about simulating measurements and using

formula boxes, signal analysis tools (e.g., FFT) and various displays. You’ll

also see how easily data can be saved to an external file.

Genera te  da ta
1. Start a new program by selecting File → New.

2. To simulate data, select the Device → Virtual Source → Function

Generator and position the object in the upper left section of the display.

3. Set the following values in the Function Generator:
Function: “Square”        (in the pull down menu)

Frequency: “100”
Amplitude: “1”
DcOffset: “0”
Phase: “Deg 0”
TimeSpan: “20m”
NumPoints: “100”

4. Get a second function generator and place it below the first one.  An
easy way to do this is to clone the first--simply click on the box in the
upper left corner of the object and select Clone. 

5. Modify the values of the second function generator as follows:
Function: “Sine”
Frequency: “100”
Amplitude: “1v
DcOffset: “0”
Phase: “Deg 0”
TimeSpan: “20m”
NumPoints: “100”

6. Rename the two objects.  Position the mouse arrow over the function
generator that generates the square wave and click the right mouse
button.  Select Properties.  Change the name in the Title field to
Square and click on OK. Change the name of the second function
generator object to Sine.

7. Minimize the two function generators. Click the upper right corner of
the icon (with the left mouse button) to minimize the object.
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Mult ip ly  the  Two Signal s
1. Select Device → Function & Object Browser → Type: Operators,

Category: Arithmetic, Member:* (i.e., multiplication of numbers).
Select Create Formula, and an input box for a formula appears.  In
this case, “a*b” is given as a formula.  However, this formula can be
edited (just like all other formulas in HP VEE).

2. Click in the formula window and add 1.5 to “a*b” (i.e., “a*b+1.5”).

Note: HP VEE provides several ways of working with formulas:

• You can type in any formula using Device → Formula.

• You can incorporate pre-fabricated formulas for many math,

engineering, and scientific functions from Device → Function &

Object Browser (or press the ƒx key).

• You can edit and nest formula objects, creating larger formulas.

3. Change the name of the formula object so that you can move through
your program more easily.  Position the mouse arrow over the formula
object and click the right mouse button.  Select Properties.  Change the
name in the Title field to “a*b+Const” and click on OK.  Click the
upper right corner of the open view (with the left mouse button) to
minimize.

4. Transfer the data from the Square object to the formula by connecting
its data output pin to the upper data input pin on the formula box.
Transfer the data from the object Sine to the formula by connecting
the data outputs to the lower data input (B) on the formula box.

Note: HP VEE can handle different data types.  In this example, the

formula object recognizes the incoming data type (i.e., fields with 100

real values) and processes them correctly.

Display  the  Data
1. Use the Display → XYTrace to display the data.  Note that the XY

Display shows one data input pin. You will need three-one for each
output from the virtual function generators and one for the output from
the formula box.

2. To add a data input, click on the box in the upper left corner of the
display and select AddTerminal... → Data Input.  This generates a
second input on the XY Trace display.  Now, add a third input for data. 

3. Transfer the values of the two function generators and the data from the
a*b+1.5 formula to the three data inputs on the XYTrace display object.
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4. Click on the Run icon (the triangular shape) in the tool bar to run the
program.

Per form an  FFT  on  t he  S quar e  Wave
1. Get Display → Spectrum(Freq) → MagnitudeSpectrum.

2. Transfer the data from the Square object to the MagnitudeSpectrum

(i.e., FFT) object.

3. Minimize the XY Trace.

4. Run the program.

Save  the  Analyz ed  D at a  t o  a  F i l e
1. Get the I/O → To → File object.  

2. Transfer the data from the Sine Function Generator to the To File

object (input pin A).

3. Click on the To File: my File button in the To File object. Enter a
suitable directory and file name (e.g., c:\temp\ex_2).  Click on OK.

4. Click on the box next to Clear File At PreRun & Open to specify
that an existing file with the same name will be overwritten.

5. To specify what is sent to the file, double-click on the (first) line with a
dark blue background with the text “WRITE TEXT a EOL”.  Leave
the settings for the first two input windows at their default settings:
WRITE and TEXT.  Replace a  with the text “Sine Data” (in quotation
marks) in the third window.  Close the transaction window with OK.
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6. Double-click immediately below the command line that was just defined.
Replace a with the  string “_______________” (in quotation marks) in the
transaction window.  Close the transaction window with OK.

7. Double-click on the third command line in To File.  

• Leave the parameters for the first three windows as WRITE, TEXT

and a.  This writes the text passed through the variable a  from the
Square function generator.

• Select REAL FORMAT instead of DEFAULT FORMAT.

• Click on DEFAULT FIELD WIDTH.  The key will change to FIELD

WIDTH.  Enter the number 4 instead of 20.

• Change the sign format from /- to ‘’ /-. 

• Change the number format from STANDARD to SCIENTIFIC.

• Change the number of decimal places (NUM FRACT DIGITS) from
6 to 3.

• Conclude your inputs with OK.

8. Get a display object for numbers and strings (text) using Display →

AlphaNumeric.  Drag the object out lengthwise by positioning the
mouse pointer over the lower right corner of the object and dragging
the corner.

9. Transfer the data from the Sine function generator to the alphanumeric
display. 

10. Click on the Run button in the tool bar to start the program.  Your HP
VEE program should look something like the screen below.

11. Check the format of the saved file using an editor.
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Example 3: Data Transfer, User

Functions and Panels

This exercise demonstrates using input/output objects, customizing

objects using the Properties dialog box, structured programming with user

objects, creating and invoking user functions, and the use and structure of

user panels. Here’s the plan:

• Data will be simulated and displayed.

• The program will be structured (i.e., parts of the program will be
“packaged” into a new object).

• The data will be analyzed and then packaged as a user function.

• Two front panels (main program, user function) with operating objects
will be constructed.

Genera te ,  Proce ss  and  D i sp l ay  D at a
1. Open a new window with File → New.  

2. Get a Device → Virtual Source → Function Generator object to
simulate measured data and a Device → Virtual Source → Noise

Generator function to add noise to the system.  Use the default values
for each object.

3. To add the outputs from these two objects together use Device →

Function & Object Browser → Type: Operators, Category:

Arithmetic, Member:+.  Select Create Formula.

4. Connect the output of the function generator to input pin A on the A+B

object, and connect the output of the noise generator to input pin B. 

5. Get the Display → XY Trace object, and connect the output pin
Result from the A+B object to the input pin of the XY Trace.

6. Click on the triangular button in the tool bar to run the program.

Add a  S l ider  and  a  C ont r o l  K nob
1. Get the Data → Continuous → Integer Slider object and position it

to the left of the function generator.  If you need more room, simply
click in a clear space in the work area to move the HP VEE program.
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2. Add an input terminal to the function generator--click on the box in the
top left corner of the function generator and select Add Terminal →

Data Input. Click on Frequency and OK.  Now, the frequency is
controlled through the input terminal.  

3. Connect the slider’s output pin to the Frequency input pin of the
function generator.

Note: Additional pins can be created for almost all objects so that data

(Data Input/Output) or control parameters (Control Input/Output) can

be transferred.  For example, you can transfer variables to formulas,

values to objects, data records to graphics, and much more.

4. Get Data → Continuous → Real Knob.  

5. Add an input terminal to the noise generator to control the amplitude.

6. Set up both controls so that the program runs when the operator adjusts
either the frequency or noise amplitude.  Click on the box in the upper
left corner of the Slider object and select Properties; click on the box
next to Auto Execute; click on OK.  Repeat for the Knob object.

Note: You can change the upper and lower limits of the slider and the

knob by typing in new values in the appropriate windows.

7. Minimize the function generator and noise generator objects.

8. Run the program by adjusting either the frequency or noise amplitude
by moving the slider bar and the knob dial.  Your display screen should
look something like this.
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With HP VEE, groups of objects can be “packaged” into a new object

(UserObjects).  This increases clarity, saves space on the display screen,

and allows functional units to be reused.

Create  a  UserObj ect  
1. Highlight all the objects for inclusion in the UserObject by holding

down the Ctrl key while clicking on the function generator, the noise
generator and the A+B object.  Notice that the selected objects have a
shadowed background. 

2. Click on the Edit menu and select Create UserObject.  

3. Enter “simulation” as the name in the title field and click on OK.  HP
VEE draws a frame around the selected objects, including the input and
output pins.

4. The user object simulation now occupies the whole of the display
screen.  Close the user object frame by clicking on the x in the upper
right corner of the frame-be sure not close HP VEE by clicking on the x
in the extreme upper right corner!

5. Run the program by adjusting the slider or knob values.  The program
should run exactly as it did before you created the user object.

Note: To see the structure of your program, go to the View menu.  If

there is not a checkmark next to Program Explorer, click on Program

Explorer to toggle it on.  Now the left side of your HP VEE display area

lists the elements of your program-in this case Main and simulation.

To free up space for the rest of this example, turn off the Program

Explorer now.

Create  a  User  Panel
1. Select the slider, the knob, and the display by holding down the Ctrl

key and clicking on each object using the left mouse button.

2. Go to the Edit menu and select Add To Panel.  HP VEE creates a new
window containing just the objects you selected. 

3. Enlarge the new window by dragging the mouse from the lower right-
hand corner.  Rearrange the objects so that they are all visible.  Change
the size of each object if you wish.
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4. Use the buttons in the upper left corner of the header bar to switch
between the Panel View and the complete visual program (i.e.,
development mode or Detail View).

5. To run the program in Panel View, adjust the slider and knob. Again, the
program should run exactly as it did when you ran it in Detail View
(i.e., the development mode).

Cont ro l  Program Execut i on  F l ow
Linking objects via their sequence pins specifies the order in which the

program is executed.  HP VEE programs execute top to bottom, left to

right-unless the sequence pins are used to further control program

execution.

1. Switch back to Detail View using the right-most button of the three in
the header bar (next to “Main”).  

2. Connect the sequence pin on the bottom of the slider with the sequence
pin on the top of the knob.  

3. Get the Flow → Confirm (OK) object.  Connect the bottom sequence
pin of the knob to the top sequence pin of the OK object.

Note: The Confirm (OK) button stops program execution at the point

where the button is located.  

4. Change the label on the OK button to Press for stats.  Click on the
right mouse button while the mouse is over the button, select the
Properties menu, and type in the new label in the Title field. 

5. Enlarge the button so that the label is clearly displayed.

6. Click on the OK object to select it and then Edit → Add to Panel so
that the Press for Stats button is accessible to the program operator
(i.e., in the Panel View).

7. Run the program (adjust either slider or knob) and click on the button
when it is activated.
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Set  a  Global  Var i ab l e
1. Switch back to the Detail View using the right-most button of the three

in the header bar (next to “Main”).  

2. Maximize the development window by clicking on the box in the right
corner of the header bar.  

3. Get the Data → Variable → Set Variable object and transfer the
simulated data from the Simulation object (i.e., connect the output pin
Result from the simulation UserObject to the input pin on the Set

Variable object).

4. Rename the default globala to be sim_data by typing the new name in
the field.

Note: Global variables can be used anywhere in an HP VEE program

using the Set/Get Variable object, and the variable data is passed

without connecting the objects through input/output pins.

Create  a  Subrout i ne  ( U ser Funct i on )  t ha t  C al l s  t he  G l obal
Var iab le
1. Select Device → UserFunction.  This provides a self-contained

function in which you can create a stand-alone routine.

2. Get a Data → Variable → Get Variable.  Change the name in the field
to sim_data to match the name of the global variable set up earlier. 

3. Select Device → Function & Object Browser (or the ƒx key in the
tool bar) and Type: Built-In Functions, Category: Probability &

Statistics, Method:max.  Select Create Formula.

ƒx key → Type: Built-In Functions, Category: Probability &

Statistics, Method:min.  Select Create Formula.

ƒx key → Type: Built-In Functions, Category: Probability &

Statistics, Method:median.  Select Create Formula.

4. Connect the output pin from the global variable object sim_data to the
input pins of the maximum, minimum, and median function boxes.

5. Get a Display → Alphanumeric.

6. Clone it twice so that you have three displays.  To clone an object, click
on the box in the upper left corner of the object and select Clone.
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7. Change the name of each object to maximum, minimum, and median

respectively.  To change an object’s name, click the right mouse button
while on the object, select Properties, and type in the new name in the
Title field.

8. Connect the output pins of the max, min, and median functions to their
respective alphanumeric displays.

9. Get a Flow → Confirm (OK) button.  Connect the bottom sequence pin
of the Get Variable (sim_data) to the top sequence pin of the OK

button.

10. Change the label on the OK button (for clarity during program
execution) to Close stats panel.  

11. Resize the button so that the label is clearly displayed.

12. Create an operator panel for the user function that contains the three
displays plus the Close stats panel button. Press the Ctrl key while
clicking on each object and then select Edit → Add to Panel.  Arrange
the objects as desired and size the operator panel as appropriate.

13. Move the objects on the Panel and resize the whole panel as desired.

14. While in Panel View, open the user function’s Properties menu (click
the right mouse button above the blue header bar of the function).
Select Properties, ensure that box next to Show Panel On Execute

has a checkmark in it.  

15. While in the Properties dialog box, rename the user function Analysis

by typing in the new name in the Title field.  Click on OK.

Note: Show Panel On Execute displays the panel while the program is

running.  This program pauses at the Close stats panel button (i.e.,

the panel remains open until the button is clicked).

16. Close the function (click on the x in the upper right of the frame).

17. Use the Program Explorer to view your program so far-you can click on
the + symbol next to Local User Functions to go to the Analysis user
function.  Toggle back and forth between the panel view and the
complete visual code in the detail view.  
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Cal l  the  User  Fu nct i on  f r om t he  M ai n  P r ogr am
1. Go to the Detail View for the Main program with Program Explorer off.

2. Select Device → Call and position the object in the lower part of the
main program.

3. Replace the default name myfunction with Analysis, which is the
name of the user function to be called.

4. Connect the bottom sequence pin of the Press for stats button to the
top sequence pin of the Call Analysis object. 

5. Run the completed program-go to panel view and adjust the slider or
knob.

The program should run as follows:

• HP VEE displays the simulated data, but stops execution until you click
Press for stats button.

• After you have clicked on the button, HP VEE displays the panel for the
user function, showing the displays for the maximum, minimum, and
median values.

• The panel stays open until you click on the Close stats panel button.

Here’s the Main program.
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Here’s the Analysis user function.

Here’s the Main user panel.
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Here’s the Analysis user function panel.

Troubleshooting Tips

If this program doesn’t run as you expect or HP VEE gives you an error

message, try the following steps:

• Stop the program if it is still running-to stop, press the box on the tool
bar or select Debug → Stop.

• Ensure that the objects are connected as shown in the illustrations. 

• Ensure that the global variable name sim_data is correct in the Set/Get
Variable objects.

• Ensure that the user function name Analysis is correct in the Call object.

• Use Debug → Show Data Flow and Debug → Show Execution Flow

to see whether data is flowing and the program is executing as expected-
be sure to turn off the panels first so that you can actually see the data
and execution flow.  To turn off the panels (for both Main and
Analysis), go to the panel view, right mouse click and select
Properties, then turn off Show on Execute.
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CTRL N

New

+ CTRL O

Open

+ CTRL S

Save

+ CTRL G

Run/Resume

+ CTRL P

Pause

+ CTRL T

Step Into

+

Real

3.14

Formula

2*A+3A Result

Shift CTRLA + Click

Click
on line

Delete Line

CTRL Click and 
drag on object

Clone Object

CTRL Click on
each one

Select Several Objects

Terminal Name Tip

Line Probe

Double
Click

Delete Object

Double
Click

Edit Properties

Shift Click

Highlight Connected 
Lines and Objects

CTRL

Select All Objects

+

A

Add Terminal

Esc

Cancel Edit

CTRL +D

Delete Terminal

CTRL ++

Hover cursor
over terminal

Pop Up Edit Menu

Right mouse click
in work area

Pop Up Object  Menu

Right mouse click
on object
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Amplicon Liveline offers a complete range of PC plug-in cards for data
acquisition, serial and HPIB communications, industrial rack mounted
PCs and single board computers. PC hardware solutions are available

from 16 different suppliers to ensure that Amplicon can meet the varied demands from industry,
higher education and research and development. All products offer support for HP VEE and are
presented in a 320 page color catalog with full pricing and technical details.

Brighton, United Kingdom  •  +44 (0) 1273 570220  •  www.amplicon.co.uk

ComputerBoards, Inc. offers a complete line of 12-
bit and 16-bit PC data acquisition products.  The 16-

bit products include replacements for all standard 12-bit boards, including PCI and PCMCIA
boards, high-channel-count analog input boards, and 1 MHz 16-bit ISA and PCI boards.
ComputerBoards Universal Library provides drivers for HP VEE.

Middleboro, Massachusetts  •  (508) 946-5100  •  www.computerboards.com

CyberResearch distributes products from several PC plug-in data acquisition
manufacturers.  CyberResearch has a staff of experienced application engineers
who will assist customers with their PC plug-in data acquisition needs.
CyberResearch also distributes products from over 100 vendors.  These products

include rack-mount and portable PCs and PC products useful to test, measurement and data
acquisition engineers.

Branford, Connecticut  •  (800) 341-2525  •  www.cyberresearch.com

Data Translation offers the DT VPI visual programming
interface, which connects HP VEE to the DT-Open Layers
standard API.  This provides HP VEE support for virtually all

Data Translation data acquisition boards.  This includes the high performance PCI-EZ Series for
PCI-based data acquisition, the PC Card-EZ Series for portable PCMCIA applications, and a
broad line of PC/AT data acquisition boards. The PCI-EZ Series range from 16 to 64 analog
inputs at 330KSa/s and 12-bit resolution to 16 analog inputs at 100 to 200KSa/s at 16-bit
resolution.  The PCI-EZ boards also include two analog outputs, eight digital I/O and one
counter/timer to complete the application.  Support is available for both Windows 95 and
Windows NT.

Marlboro, Massachusetts  •  (508) 481-3700 or (800) 525-8528  •  www.datatranslation.com

Meilhaus Electronic data acquisition products cover a range of hardware and
software products for standard applications as well as for highly sophisticated test,
measurement and control systems based on a PC platform.  Products include data
acquisition cards for PCI and PCMCIA bus, IEEE488 cards, HP-IB/LAN gateway,

sensor modules, intelligent sensor interfaces, and system integration services.

Puchheim, Germany  •  ++089 \ 89 01 660  •  www.meilhaus.de

®

Worldwide Partners

Through contracts with leading instrument suppliers, HP provides total

solutions for test, measurement and data acquisition.  Companies

worldwide offer hardware/software solutions based on HP VEE.



(

27

5 Reasons to call Today!

Easier Programming

HP VEE 5.0 can load and run any ActiveX Control.  Now you can quickly

customize your HP VEE programs with barcode readers, high-speed

graphics, calendars, buttons, knobs and literally thousands of other

ActiveX Controls.  

Easier Data Interchange

With its ActiveX Automation technology, HP VEE 5.0 lets you use popular

word processors for documentation, commercial spreadsheets for data

analysis, and off-the-shelf database applications for archiving data.  Choose

what you want to use—HP VEE supports it!

Easier Access

With its built-in web server, HP VEE 5.0 allows you to access instruments

over the intranet or World Wide Web, making it easy to troubleshoot

systems, retrieve information, and monitor test systems remotely.

Easier Licensing

With a new mini-site license for up to ten users, HP VEE 5.0 allows you to

get bulk discounts on smaller orders, making it easier than ever to put this

powerful tool in the hands of those who need it.

We’re Easy to Reach

It’s never been easier or more affordable to put HP VEE to work for you.

Find the HP DIRECT or HP Call Center representative nearest you on the

next page. Call today!
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Australia
Phone Number: 1-800-143-243
Austria
Phone Number: (01) 25000-7171 
Fax: (01) 25000-7172 
E-Mail Address: Messtechnik_vertrieb@hp.com 
Belgium
Phone Number: 02/778 3417 
Fax: 02/778 3414 
Brazil
Phone Number: 0-800-130-266 
Additional phone number(s): (011) 726-8155 
Fax: (011) 726-8171
Canada
Phone Number: (800) 387-3154 
Fax: (905) 206-4700 
China
Phone Number: (010) 65050149
Czech Republic
Phone Number: 42/2/2435 5808 
Fax: 42/2/2435 5809 
Finland
Phone Number: 358-9-8872 2100 
Fax: 358-9-8872 2923 
E-Mail Address: tmodirect@finland.hp.com 
France
Phone Number: 01 69 29 41 14 
Fax: 01 69 82 65 35 
Germany
Phone Number: (0180) 524-63 33 
Fax: (0180) 524-63 36 
E-Mail Address: Messtechnik_vertrieb@hp.com 
Greece
Phone Number: 30/1/726 40 45 
Fax: 30/1/726 40 20 
Hong Kong
Phone Number: 800-930-871
India
Phone Number: 000-6517MTF278-1596
Israel
Phone Number: 972/3/53 80 378 
Fax: 972/3/53 76 505 

Italy
Phone Number: 02 - 9212.2241 
Fax: 02 - 9210.4069 
E-Mail Address: hpi_direct@hp-italy-
gen3.om.hp.com 
Japan
Phone Number: 81-426-56-7832 
Fax: 81-426-56-7843 
Korea
Phone Number: (02) 784-7084
Netherlands
Phone Number: 020-547 6222 
Fax: 020 547 7764 
Norway
Phone Number: +47 2273 5759 
Fax: +47 2273 5619 
E-Mail Address:
test_measurement@norway.hp.com 
Poland
Phone Number: 48-22-7230066 
Fax: 48-22-7230066 
South Africa
Phone Number: 27-11-806 1173 
Fax: 27-11-806 1213 
Spain
Phone Number: (91) 631.13.23 
Fax: (91) 631.14.69 
Sweden
Phone Number: (46/8) 444 2277 
Fax: (46/8) 444 2525 
E-Mail Address: test-
measurement@sweden.hp.com 
Switzerland
Phone Number: (01) 735 72 00 
Fax: (01) 735 72 90 
E-Mail Address: Messtechnik_vertrieb@hp.com 
Taiwan
Phone Number: (02) 2717-9680
United Kingdom
Phone Number: 01344-366666 
Fax: 01344-362852 
United States
Phone Number: (800) 452-4844 
Fax: (303) 662-3726

HP DIRECT & Call Centers
In certain regions of the world HP DIRECT or Call Centers offer online
technical information and sales assistance. You can ask for literature or, in
some cases, request products for evaluation. The HP DIRECT or Call
Center team can help you with your application needs- they’re only a
phone call away. If you are in a country without HP DIRECT or a Call
Center, or if you want to speak with a local HP representative, please
contact the sales office in your local region.
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United States:

Hewlett-Packard Company
Test and Measurement Call Center
P.O. Box 4026
Englewood, CO 80155-4026
1 800 452 4844  

Canada:

Hewlett-Packard Canada Ltd.
5150 Spectrum Way
Mississauga, Ontario
L4W 5G1
(905) 206 4725 

Europe:

Hewlett-Packard
European Marketing Centre
P.O. Box 999
1180 AZ Amstelveen
The Netherlands
(31 20) 547 9900

Japan:

Hewlett-Packard Japan Ltd.
Measurement
Assistance Center
9-1, Takakura-Cho, Hachioji-Shi,
Tokyo 192, Japan
Tel: (81) 426 56 7832
Fax: (81) 426 56 7840       

Latin America:

Hewlett-Packard
Latin American Region Headquarters
5200 Blue Lagoon Drive
9th Floor
Miami, Florida 33126
U.S.A.
Tel: (305) 267-4245          
(305) 267-4220
Fax: (305) 267-4288

Australia/New Zealand:

Hewlett-Packard Australia Ltd.
31-41 Joseph Street
Blackburn, Victoria 3130
Australia
1 800 629 485               

Asia Pacific:

Hewlett-Packard Asia Pacific Ltd.
17-21/F Shell Tower, Times Square,
1 Matheson Street, Causeway Bay,
Hong Kong
Tel: (852) 2599 7777
Fax: (852) 2506 9285

For more information about Hewlett-Packard test & measurement

products, applications, services, and for a current sales office 

listing, visit our web site, http://www.hp.com/go/tmdir. You can 

also contact one of the following centers and ask for a test and

measurement sales representative.  
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